atftp is a client/server implementation of the TFTP protocol that implements RFCs 1350, 2090, 2347, 2348, 2349 and 7440.
atftp stands for Advanced Trivial File Transfer Protocol. It is called “advanced”, by contrast to other TFTP servers, for two reasons. Firstly, it is intended to be fully compliant with all related RFCs. This include RFC1350, RFC2090, RFC2347, RFC2348 and RFC2349. Secondly, atftp is intended for serving boot files to large clusters. It is multi-threaded and supports multicast (RFC2090 and PXE), allowing faster boot of hundreds of machines simultaneously.
The server is multi-threaded and the client presents a friendly interface using libreadline.
This is free and open source software.
Website: github.com/madmartin/atftp
Support:
Developer: Jean-Pierre Lefebvre, Remi Lefebvre, and contributors
License: GNU General Public License v2.0

atftp is written in C. Learn C with our recommended free books and free tutorials.
Related Software
| Command-line FTP Clients | |
|---|---|
| NcFTP | Popular console based user interface File Transfer Protocol (FTP) client program |
| LFTP | Mature open source file retrieving tool |
| termscp | Feature rich terminal file transfer and explorer, with support for SCP/SFTP/FTP/S3 |
| SuppaFTP | FTP/FTPS client library and built-in command-line FTP client |
| tnftp | Based on the original BSD FTP client |
| cbftp | Advanced, multi-purpose client that focuses on efficient large-scale data spreading |
| lssh | List-based ssh, scp, sftp client |
| atftp | Client/server implementation of the TFTP protocol |
| Yafc | Intended to be a replacement for the standard ftp program |
Read our verdict in the software roundup.
Explore our carefully curated directory of recommended free and open source software, covering every major software category.The directory forms part of our extensive collection of articles for Linux enthusiasts. It includes hundreds of detailed reviews, together with free and open source alternatives to proprietary software from companies such as Google, Microsoft, Apple, Adobe, IBM, Cisco, Oracle, and Autodesk. LinuxLinks also covers interesting projects worth exploring, Linux-compatible hardware, free programming books and tutorials, and much more. Know a useful free and open source Linux application that we haven’t covered? Tell us about it using our submission form. |


Please read our Comment Policy before commenting.